Page 1 of 1

windriver install problem

PostPosted: Tue May 19, 2020 11:58 am
by andylgh
i bundle the demo to zynq7035 board,and i download bit into PL,the PC(win7 system) find pci device in device manager,but when i follow <<xillybus_getting_started_windows.pdf>> to install driver, this step is failed and Tips:Windows cannot install PCI device

can you help to slove this problem ,thanks!!!!!

Re: windriver install problem

PostPosted: Tue May 19, 2020 12:20 pm
by support
Hello,

Could you please be more specific on which board exactly and what you've done until reaching the error?

I should mention that if you've made any changes in Xilinx' PCIe block, it might have altered the Vendor and Product IDs without asking for it. So as a first step, I suggest verifying that these are 0x10ee and 0xebeb, respectively.

Regards,
Eli

Re: windriver install problem

PostPosted: Wed May 20, 2020 12:17 pm
by andylgh
thanks for anwser,i found the problem,i use the zynq board the xillybus.inf need to change : %Xillybus.DRVDESC%=Xillybus_Inst, PCI\VEN_10EE&DEV_7024

Re: windriver install problem

PostPosted: Wed May 20, 2020 12:31 pm
by support
Hello,

I understand that you changed the driver's information to match the incorrectly updated product ID. That is indeed one way to solve the problem, but it's better to change the product ID in the FPGA design. Among others, because you might want to use the driver with some other design in the future, and suddenly it won't work again.

Regards,
Eli

Re: windriver install problem

PostPosted: Wed May 20, 2020 1:01 pm
by andylgh
thanks for your advice!! i will try this mothod

Re: windriver install problem

PostPosted: Wed May 20, 2020 1:11 pm
by andylgh
i check the fpga design
pcie VID = 10EE
pcie DID = 7024 (device id)
pcie RID = 07 (Rivision ID)
pcie subsystem vender id = 10EE
pcie subsystem id = EBEB

if i want to use default xillybus.inf,need i change DID value to EBEB?

Re: windriver install problem

PostPosted: Wed May 20, 2020 1:25 pm
by support
Yes, I suppose so. But it's more common to do this correction with Vivado's GUI. Or possibly even better, to use the configuration file that came with the bundle. If you made any changes, make sure nothing else changed along with it.

Regards,
Eli

Re: windriver install problem

PostPosted: Wed May 20, 2020 1:27 pm
by andylgh
thanks for reply rapid